aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSquibid <me@zacharyscheiman.com>2024-08-08 03:30:24 -0400
committerSquibid <me@zacharyscheiman.com>2024-08-08 03:30:24 -0400
commit8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3 (patch)
treeb1ebcf4836ccf2899a8105d83677e67f9a2f5835
downloadvoidpkgs-8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3.tar.gz
voidpkgs-8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3.tar.bz2
voidpkgs-8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3.zip
initial commit
Diffstat (limited to '')
-rw-r--r--.gitignore2
-rw-r--r--README.md8
-rwxr-xr-xbuild.sh22
-rw-r--r--srcpkgs/vesktop/template40
4 files changed, 72 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..98be306
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+dest/
+void-packages/
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..49f603e
--- /dev/null
+++ b/README.md
@@ -0,0 +1,8 @@
+# A bunch of packages that I want on void
+For a list of packages look at the srcpkgs directory.
+
+To install the packages in this repo make a file like called:
+/etc/xbps.d/squibid.conf with the following:
+```conf
+repository=https://voidpkgs.squi.bid
+```
diff --git a/build.sh b/build.sh
new file mode 100755
index 0000000..79d7064
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+# a small script to help me compile all packages and push them to my server
+
+set -e # exit asap
+
+mkdir -p ./dest
+[ ! -d void-packages ] && git clone --depth 1 https://github.com/void-linux/void-packages.git
+./void-packages/xbps-src binary-bootstrap
+
+for f in srcpkgs/*; do
+ cp ./"$f" ./void-packages/"$f" -ru
+ ./void-packages/xbps-src pkg "$f"
+ cp ./void-packages/hostdir/binpkgs/*.xbps ./dest/ -u
+done
+
+# copy repodata after building all packages
+cp ./void-packages/hostdir/binpkgs/x86_64-repodata ./dest/
+
+# tell the builder to sign their packages
+printf "\n\n\033[1;31mRun the following commands:\033[m\n"
+printf 'xbps-rindex -s ./dest --privkey \033[31m/path/to/key\033[m --signedby \033[31m"Name <Email>"\033[m\n'
+printf 'xbps-rindex -S ./dest/* --privkey \033[31m/path/to/key\033[m\n'
diff --git a/srcpkgs/vesktop/template b/srcpkgs/vesktop/template
new file mode 100644
index 0000000..c7e60ea
--- /dev/null
+++ b/srcpkgs/vesktop/template
@@ -0,0 +1,40 @@
+# Template file for 'vesktop'
+pkgname=vesktop
+version=1.5.3
+revision=1
+archs="x86_64"
+short_desc="custom Discord App"
+maintainer="Zachary Scheiman <me@zacharyscheiman.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/Vencord/Vesktop"
+distfiles="https://github.com/Vencord/Vesktop/releases/download/v${version}/vesktop-${version}.tar.gz"
+checksum=5ab37924e87bd7beb19ce2cc6599c280be765f1577573f014918fb60b5a7cd86
+
+do_install() {
+ local package_location="usr/lib/$pkgname" item
+ vmkdir ${package_location}
+ chmod +x vesktop
+ for item in \
+ locales \
+ resources \
+ vesktop \
+ libffmpeg.so \
+ snapshot_blob.bin \
+ icudtl.dat \
+ libEGL.so \
+ libGLESv2.so \
+ chrome_100_percent.pak \
+ chrome_200_percent.pak \
+ chrome-sandbox \
+ chrome_crashpad_handler \
+ resources.pak \
+ libvulkan.so.1 \
+ v8_context_snapshot.bin \
+ libvk_swiftshader.so \
+ vk_swiftshader_icd.json
+ do
+ vcopy "${item}" "${package_location}"
+ done
+ vmkdir usr/bin
+ ln -sfr $DESTDIR/${package_location}/vesktop $DESTDIR/usr/bin/vesktop
+}