aboutsummaryrefslogtreecommitdiffstats
path: root/build.sh
diff options
context:
space:
mode:
authorSquibid <me@zacharyscheiman.com>2024-08-08 03:30:24 -0400
committerSquibid <me@zacharyscheiman.com>2024-08-08 03:30:24 -0400
commit8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3 (patch)
treeb1ebcf4836ccf2899a8105d83677e67f9a2f5835 /build.sh
downloadvoidpkgs-8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3.tar.gz
voidpkgs-8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3.tar.bz2
voidpkgs-8d2f9bcee4c3b6fbbb225eabf7ad207da01f3fa3.zip
initial commit
Diffstat (limited to '')
-rwxr-xr-xbuild.sh22
1 files changed, 22 insertions, 0 deletions
diff --git a/build.sh b/build.sh
new file mode 100755
index 0000000..79d7064
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+# a small script to help me compile all packages and push them to my server
+
+set -e # exit asap
+
+mkdir -p ./dest
+[ ! -d void-packages ] && git clone --depth 1 https://github.com/void-linux/void-packages.git
+./void-packages/xbps-src binary-bootstrap
+
+for f in srcpkgs/*; do
+ cp ./"$f" ./void-packages/"$f" -ru
+ ./void-packages/xbps-src pkg "$f"
+ cp ./void-packages/hostdir/binpkgs/*.xbps ./dest/ -u
+done
+
+# copy repodata after building all packages
+cp ./void-packages/hostdir/binpkgs/x86_64-repodata ./dest/
+
+# tell the builder to sign their packages
+printf "\n\n\033[1;31mRun the following commands:\033[m\n"
+printf 'xbps-rindex -s ./dest --privkey \033[31m/path/to/key\033[m --signedby \033[31m"Name <Email>"\033[m\n'
+printf 'xbps-rindex -S ./dest/* --privkey \033[31m/path/to/key\033[m\n'